TChart i ActiveX errors

dział ogólny

TChart i ActiveX errors

Nowy postprzez krzychu019 » poniedziałek, 4 listopada 2013, 13:40

Witam,

Mam problem z TChart i ładowaniem ActiveX. W skrócie: dwa projekty .ocx zawierające w sobie TChart-a. Jeśli pod IE załadowane są na osobnych stronach nie ma problemu, działają ok. Problem jest gdy używamy pojedynczej strony, ładujemy pierwszego ActiveX-a po czym zmieniamy tylko url-a by załadować drugiego na tej samej stronie - totalny crash.

Z pierwszego ActiveX-a destruktor jest poprawnie wywołany więc komponent TChart powinien być poprawnie usunięty (próbowałem dając komponent na forme jak i tworzyć dynamicznie), niestety przy reloadzie strony sypią się błędy postaci "A class ... already exist" gdzie classy to np TChartAxistTitle i inne.

Jakieś sugestie?

Pozdrawiam
Avatar użytkownika
krzychu019
Bladawiec
Bladawiec
 
Posty: 10
Dołączył(a): poniedziałek, 11 czerwca 2012, 11:25
Podziękował : 0
Otrzymał podziękowań: 0
System operacyjny: brak systemu
Kompilator: brak kompilatora
Gadu Gadu: 0
    Windows 7Firefox

Re: TChart i ActiveX errors

Nowy postprzez krzychu019 » poniedziałek, 4 listopada 2013, 15:52

Odpowiadam sam sobie :)

Wszystkie ActiveX muszą być zbudowane z tą samą listą packages i wszystko działa ok.
Avatar użytkownika
krzychu019
Bladawiec
Bladawiec
 
Posty: 10
Dołączył(a): poniedziałek, 11 czerwca 2012, 11:25
Podziękował : 0
Otrzymał podziękowań: 0
System operacyjny: brak systemu
Kompilator: brak kompilatora
Gadu Gadu: 0
    Windows 7Firefox


  • Podobne tematy
    Odpowiedzi
    Wyświetlone
    Ostatni post

Powrót do Ogólne problemy z programowaniem

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zalogowanych użytkowników i 10 gości

cron