Problem z szablonem funkcji w nagłówku

dział ogólny

Problem z szablonem funkcji w nagłówku

Nowy postprzez beherit » niedziela, 25 stycznia 2015, 22:48

Próbuję przetłumaczyć z Delphi następującą rzecz (klik). Wszystko pięknie ale dostaję następujący błąd:

Kod: Zaznacz cały
[ilink32 Error] Error: Unresolved external '__stdcall GetLangStr(System::UnicodeString)' referenced from <ścieżka>


Szczerze mówiąc nie wiem co robię źle i czemu wyrzuca mi błąd z UnicodeString. Ktoś może pomóc? Aktualne przetłumaczenie plików:

https://www.dropbox.com/s/f3vm8do989qhv ... API.h?dl=0
https://www.dropbox.com/s/kldrqy8yqs1hw ... I.cpp?dl=0
Ostatnio edytowano poniedziałek, 26 stycznia 2015, 01:00 przez beherit, łącznie edytowano 1 raz
Obrazek
Avatar użytkownika
beherit
Homos antropiczny
Homos antropiczny
 
Posty: 62
Dołączył(a): poniedziałek, 16 lutego 2009, 19:55
Lokalizacja: Jarocin
Podziękował : 2
Otrzymał podziękowań: 0
System operacyjny: Windows 10
Kompilator: C++Builder XE5
Gadu Gadu: 0
    Windows 7Firefox

Re: Problem z szablonem funkcji w nagłówku

Nowy postprzez polymorphism » niedziela, 25 stycznia 2015, 23:38

Nie wiem, o co chodzi z tym szablonem, ale dlaczego kompilator szuka funkcji z konwencją __stdcall, jeśli w deklaracji jest __fastcall?
C++ Reference - opis wszystkich klas STL-a i funkcji C.
Avatar użytkownika
polymorphism
Doświadczony Programista ● Moderator
Doświadczony Programista ● Moderator
 
Posty: 2156
Dołączył(a): piątek, 19 grudnia 2008, 13:04
Podziękował : 0
Otrzymał podziękowań: 199
System operacyjny: Windows 8.1
Windows 10
Linux Mint 19
Kompilator: Visual Studio
Visual Studio Code
MSYS2 (MinGW, clang)
g++
clang
Gadu Gadu: 0
    Windows 7Firefox

Re: Problem z szablonem funkcji w nagłówku

Nowy postprzez beherit » poniedziałek, 26 stycznia 2015, 00:02

A nie sorry to po prostu źle skopiowałem :)
Obrazek
Avatar użytkownika
beherit
Homos antropiczny
Homos antropiczny
 
Posty: 62
Dołączył(a): poniedziałek, 16 lutego 2009, 19:55
Lokalizacja: Jarocin
Podziękował : 2
Otrzymał podziękowań: 0
System operacyjny: Windows 10
Kompilator: C++Builder XE5
Gadu Gadu: 0
    Windows 7Firefox

Re: Problem z szablonem funkcji w nagłówku

Nowy postprzez beherit » poniedziałek, 26 stycznia 2015, 01:00

Ok już wszystko działa.
Obrazek
Avatar użytkownika
beherit
Homos antropiczny
Homos antropiczny
 
Posty: 62
Dołączył(a): poniedziałek, 16 lutego 2009, 19:55
Lokalizacja: Jarocin
Podziękował : 2
Otrzymał podziękowań: 0
System operacyjny: Windows 10
Kompilator: C++Builder XE5
Gadu Gadu: 0
    Windows 7Firefox


  • Podobne tematy
    Odpowiedzi
    Wyświetlone
    Ostatni post

Powrót do Ogólne problemy z programowaniem

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zalogowanych użytkowników i 6 gości

cron