SQL 2008 - zapytanie w builder nie zwraca wyników

Problemy związane z tworzeniem i zarządzaniem programami bazo-danowymi.
Regulamin działu


Zadając pytania dotyczące baz danych należy podawać szczegółowe informacje o bazie danych nad którą się pracuje, czyli:

  • Rodzaj serwera bazodanowego: MySql, MSSQL, Oracle itp.
  • Wersja bazy danych
  • Technologia bazodanowa używana w programie: ADO, DbExpress, InterBase
  • Komponenty użyte do zestawienia połączenia: ADOConnection, SqlConnection
  • Sposób zestawienia komponentów bazodanowych np. DataSet - DataSource - DbGrid lub DataSet - DataSetProvider - ClientDataSet - DataSource - DbGrid
  • Jeżeli używane były biblioteki innych firm niż Borland, CodeGeer i Embarcadero proszę podać ich nazwy, numer wersji i adres źródła.

SQL 2008 - zapytanie w builder nie zwraca wyników

Nowy postprzez lpss01 » sobota, 14 maja 2011, 07:41

Witam
Mam taki problem:
Robię w builderze proste zapytanie "select" i zwraca mi tylko pierwszy rekord; jak potrzebuje np. przypisać pod zmienną wartość z zapytania ale inna niż pierwsza to mam komunikat ze pole "nazwa pola" nie jest znalezione

np, wyszukuje w przykładowej tabeli "osoba" (przykładowe pola: id, imie, nazwisko) to zapytanie zwraca mi tylko pole "id" a do pola imie lub nazwisko daje komunikat ze nie znaleziono

Nie wiem dlaczego tak jest; Miałem dłuższą przerwę w programowaniu bo parę lat temu pisałem już parę aplikacji bazodanowych i jeszcze nigdy nie miałem takiego problemu; Aplikacje wcześniej napisane podpięte pod sql 2008 działają prawidłowo i builder wyszukuje wszystkie wartości w zapytaniach

Programy jakie pisałem to głównie jeszcze na sql 2000;

Prosze o pomc
Avatar użytkownika
lpss01
Bladawiec
Bladawiec
 
Posty: 1
Dołączył(a): sobota, 14 maja 2011, 07:18
Podziękował : 0
Otrzymał podziękowań: 0
System operacyjny: Win XP
Kompilator: C++ Builder 6
Gadu Gadu: 5059905
    Windows XPFirefox

Re: SQL 2008 - zapytanie w builder nie zwraca wyników

Nowy postprzez Corvis » poniedziałek, 16 maja 2011, 10:09

Jak masz zestawione połączenie chodzi mi o to jakich komponentów używasz i do jakiego komponentu odwołujesz się chcąc odczytać wartość pola ??

Na 1 rzut oka wydaje mi się, że w DataSet masz Dodane na sztywno pola (nie wszystkie jakie zwraca zapytanie SQL) i odwołujesz się do pola którego nie ma na liście.
"Sukcesy trwają, dopóki ich ktoś nie spieprzy. Porażki są wieczne"

Dr Gregory House
Avatar użytkownika
Corvis
Programista I
Programista I
 
Posty: 880
Dołączył(a): sobota, 26 lipca 2008, 00:31
Podziękował : 80
Otrzymał podziękowań: 30
System operacyjny: WINDOWS 7 64-bity
Kompilator: Praca - C++ Builder XE2 ENTERPRISE - Update 4, Dom - C++ Builder XE4 - Uddate 1
Gadu Gadu: 0
    Windows VistaChrome


Powrót do Bazy danych

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zalogowanych użytkowników i 1 gość

cron